re = /(<br\s*+\/?+>)++/i
str = 'Hello<br>
World<br><br />
Worlds<br><br><br>
Word!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end