using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[\s\S]*?([\r\n]+)[\s\S]*?""";
string input = @"<main>
<head/><body><note text=""Load"">
<note text=""2 Newlines at the end of this
newline""/>
</body>
</main>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}