re = /"[\s\S]*?([\r\n]+)[\s\S]*?"/
str = '<main>
<head/><body><note text="Load">
<note text="2 Newlines at the end of this
newline"/>
</body>
</main>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end