package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"[\s\S]*?([\r\n]+)[\s\S]*?"`)
var str = `<main>
<head/><body><note text="Load">
<note text="2 Newlines at the end of this
newline"/>
</body>
</main>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}