package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[(]?[0-9]{3}[)]?[ ,-]?[0-9]{3}[ ,-]?[0-9]{4}$`)
var str = `909-999-9999
909 999 9999
(909) 999-9999
(909) 999 9999
999 999 9999
9999999999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}