$re = '/^[(]?[0-9]{3}[)]?[ ,-]?[0-9]{3}[ ,-]?[0-9]{4}$/m';
$str = '909-999-9999
909 999 9999
(909) 999-9999
(909) 999 9999
999 999 9999
9999999999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);