re = /^[(]?[0-9]{3}[)]?[ ,-]?[0-9]{3}[ ,-]?[0-9]{4}$/m
str = '909-999-9999
909 999 9999
(909) 999-9999
(909) 999 9999
999 999 9999
9999999999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end