#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\/\*[\s\S]*\*\/"
Local $sString = "read A" & @CRLF & _
"read B" & @CRLF & _
"" & @CRLF & _
"sum := A + B" & @CRLF & _
"write sum" & @CRLF & _
"// Inline comment" & @CRLF & _
"/*" & @CRLF & _
"multiline comment" & @CRLF & _
"" & @CRLF & _
"*/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")