re = /\/\*[\s\S]*\*\//i
str = 'read A
read B
sum := A + B
write sum
// Inline comment
/*
multiline comment
*/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end