use strict;
my $str = 'p11ppppl
p1rrr11ppppl';
my $regex = qr/([a-zA-Z])(?=\1)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";