import Foundation
let pattern = #"([a-zA-Z])(?=\1)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
p11ppppl
p1rrr11ppppl
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)