$re = '/([a-zA-Z])(?=\1)/';
$str = 'p11ppppl
p1rrr11ppppl';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;