import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<TABLE\\b[^>]+>[\\s\\S]+?<TR";
final String string = "<TABLE ALIGN=\\\"RIGHT\\\" BORDER CELLSPACING=\\\"0\\\" CELLPADDING=\\\"0\\\">\n"
+ " <CAPTION><B>MESA HIGH VICTORIES</B></CAPTION>\n"
+ " <TH>Team</TH>\n"
+ " <TH>Score</TH>\n"
+ " <TR ALIGN=\\\"CENTER\\\">\n"
+ " <TD><B>Parkfield High Demons</B></TD>\n"
+ " <TD><B>28 to 21</B></TD>\n"
+ " </TR>\n"
+ " <TR ALIGN=\\\"CENTER\\\">\n"
+ " <TD><B>Burns High Badgers</B></TD>\n"
+ " <TD><B>14 to 13</B></TD>\n"
+ " </TR>\n"
+ " </TABLE>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}