re = /<TABLE\b[^>]+>[\s\S]+?<TR/
str = '<TABLE ALIGN=\\"RIGHT\\" BORDER CELLSPACING=\\"0\\" CELLPADDING=\\"0\\">
<CAPTION><B>MESA HIGH VICTORIES</B></CAPTION>
<TH>Team</TH>
<TH>Score</TH>
<TR ALIGN=\\"CENTER\\">
<TD><B>Parkfield High Demons</B></TD>
<TD><B>28 to 21</B></TD>
</TR>
<TR ALIGN=\\"CENTER\\">
<TD><B>Burns High Badgers</B></TD>
<TD><B>14 to 13</B></TD>
</TR>
</TABLE>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end