import re
regex = re.compile(r"<TABLE\b[^>]+>[\s\S]+?<TR")
test_str = ("<TABLE ALIGN=\\\"RIGHT\\\" BORDER CELLSPACING=\\\"0\\\" CELLPADDING=\\\"0\\\">\n"
" <CAPTION><B>MESA HIGH VICTORIES</B></CAPTION>\n"
" <TH>Team</TH>\n"
" <TH>Score</TH>\n"
" <TR ALIGN=\\\"CENTER\\\">\n"
" <TD><B>Parkfield High Demons</B></TD>\n"
" <TD><B>28 to 21</B></TD>\n"
" </TR>\n"
" <TR ALIGN=\\\"CENTER\\\">\n"
" <TD><B>Burns High Badgers</B></TD>\n"
" <TD><B>14 to 13</B></TD>\n"
" </TR>\n"
" </TABLE>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")