using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\s*(.+)\s+v\s*a\s*l\s*u\s*e\s*=\s*""(\w+)""\s*c\s*o\s*n\s*t\s*e\s*n\s*t\s*=\s*""(.+)""\s*\/\s*>";
string input = @"<repeat value=""2"" content=""helloworld""/>
< repeat value = ""2"" content = ""helloworld"" / >
<repeat value=""2""content=""helloworld""/>
< rep eat val ue = ""2"" con tent = ""hello world"" / >";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}