import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\s*(.+)\\s+v\\s*a\\s*l\\s*u\\s*e\\s*=\\s*\"(\\w+)\"\\s*c\\s*o\\s*n\\s*t\\s*e\\s*n\\s*t\\s*=\\s*\"(.+)\"\\s*\\/\\s*>";
final String string = "<repeat value=\"2\" content=\"helloworld\"/>\n"
+ "< repeat value = \"2\" content = \"helloworld\" / >\n"
+ "<repeat value=\"2\"content=\"helloworld\"/>\n"
+ "< rep eat val ue = \"2\" con tent = \"hello world\" / >";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}