$re = '/<\s*(.+)\s+v\s*a\s*l\s*u\s*e\s*=\s*"(\w+)"\s*c\s*o\s*n\s*t\s*e\s*n\s*t\s*=\s*"(.+)"\s*\/\s*>/';
$str = '<repeat value="2" content="helloworld"/>
< repeat value = "2" content = "helloworld" / >
<repeat value="2"content="helloworld"/>
< rep eat val ue = "2" con tent = "hello world" / >';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);