package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<td.*(File)(<[^>]*>)*:(<[^>]*>)*([\w])+\.(jpg).*td>`)
var str = `<td class='diff-addedline'><div>[[<ins class=\"diffchange diffchange-inline\">File<\/ins>:<ins class=\"diffchange diffchange-inline\">Colt3<\/ins>.jpg|thumb|none|350px|Colt 1895 machine gun .30-40 Krag]]<\/div><\/td>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}