const regex = /(.*\/[a-zA-Z0-9]{1}\/[a-zA-Z0-9]{1}\/[a-zA-Z0-9]{1}\/)(.*)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*\\\/[a-zA-Z0-9]{1}\\\/[a-zA-Z0-9]{1}\\\/[a-zA-Z0-9]{1}\\\/)(.*)', 'gim')
const str = `http://n2.sdlcdn.com/imgs/b/h/7/Fostelo-Stylish-Beige-Handbag-SDL184920551-1-2f9c2.jpg
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}