re = /(.*\/[a-zA-Z0-9]{1}\/[a-zA-Z0-9]{1}\/[a-zA-Z0-9]{1}\/)(.*)/im
str = 'http://n2.sdlcdn.com/imgs/b/h/7/Fostelo-Stylish-Beige-Handbag-SDL184920551-1-2f9c2.jpg
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end