// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)(.*\/[a-zA-Z0-9]{1}\/[a-zA-Z0-9]{1}\/[a-zA-Z0-9]{1}\/)(.*)").unwrap();
let string = "http://n2.sdlcdn.com/imgs/b/h/7/Fostelo-Stylish-Beige-Handbag-SDL184920551-1-2f9c2.jpg
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}