package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<scheme>[^:]*):host=(?P<host>[^;]*);port=(?P<port>[^;]*);dbname=(?P<database>[^;]*)$`)
var str = `mysql:host=localhost;port=3306;dbname=test"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}