// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?P<scheme>[^:]*):host=(?P<host>[^;]*);port=(?P<port>[^;]*);dbname=(?P<database>[^;]*)$").unwrap();
let string = "mysql:host=localhost;port=3306;dbname=test\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}