re = /^(?P<scheme>[^:]*):host=(?P<host>[^;]*);port=(?P<port>[^;]*);dbname=(?P<database>[^;]*)$/m
str = 'mysql:host=localhost;port=3306;dbname=test"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end