using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([#!?$])+(.html)";
string input = @"/support/how-to/how-to-convert-mp4-to-avi#.html
/support/how-to/how-to-convert-mp4-to-avi!.html
/support/how-to/how-to-convert-mp4-to-avi?.html";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}