re = /([#!?$])+(.html)/
str = '/support/how-to/how-to-convert-mp4-to-avi#.html
/support/how-to/how-to-convert-mp4-to-avi!.html
/support/how-to/how-to-convert-mp4-to-avi?.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end