$re = '~([#!?$])+(.html)~';
$str = '/support/how-to/how-to-convert-mp4-to-avi#.html
/support/how-to/how-to-convert-mp4-to-avi!.html
/support/how-to/how-to-convert-mp4-to-avi?.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);