#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\s*([JSESSIONID]+)\s*=\s*(?:"([^"])"|([^;"]*))\s*"
Local $sString = "HTTP/1.1 302 Found" & @CRLF & _
"Date: Fri, 10 Jun 2016 21:44:38 GMT" & @CRLF & _
"Set-Cookie: JSESSIONID=1n9rk5co2o4xkpr327clod1pu;Path=/genesys;Expires=Sat, 11-Jun-2016 21:44:38 GMT;HttpOnly" & @CRLF & _
"Expires: Thu, 01 Jan 1970 00:00:00 GMT" & @CRLF & _
"Location: http://192.168.1.200:8010/genesys/admin/login.jsp#/" & @CRLF & _
"Content-Length: 0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")