import re
regex = re.compile(r"\s*([JSESSIONID]+)\s*=\s*(?:\"([^\"])\"|([^;\"]*))\s*")
test_str = ("HTTP/1.1 302 Found\n"
"Date: Fri, 10 Jun 2016 21:44:38 GMT\n"
"Set-Cookie: JSESSIONID=1n9rk5co2o4xkpr327clod1pu;Path=/genesys;Expires=Sat, 11-Jun-2016 21:44:38 GMT;HttpOnly\n"
"Expires: Thu, 01 Jan 1970 00:00:00 GMT\n"
"Location: http://192.168.1.200:8010/genesys/admin/login.jsp#/\n"
"Content-Length: 0")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")