#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([A-Z](?1)*[0-9]|[0-9](?1)*[A-Z])+$"
Local $sString = "A3D4" & @CRLF & _
"A34DF5" & @CRLF & _
"22FF" & @CRLF & _
"A23B" & @CRLF & _
"A85G9F"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")