package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Z](?1)*[0-9]|[0-9](?1)*[A-Z])+$`)
var str = `A3D4
A34DF5
22FF
A23B
A85G9F`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}