$re = '/^([A-Z](?1)*[0-9]|[0-9](?1)*[A-Z])+$/m';
$str = 'A3D4
A34DF5
22FF
A23B
A85G9F';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);