using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"class (?!.*\(object\)).*";
string input = @"class Test(object):
pass
class Test:
pass";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}