$re = '/class (?!.*\(object\)).*/';
$str = 'class Test(object):
pass
class Test:
pass';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);