re = /class (?!.*\(object\)).*/
str = 'class Test(object):
pass
class Test:
pass'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end