#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-Z]{2,}\d+(*SKIP)(*FAIL)|[A-Z]\K\d+"
Local $sString = "A12B8Y9CC10" & @CRLF & _
"V5C8I17" & @CRLF & _
"KK18II9" & @CRLF & _
"I8VV22ZZ4S9U2" & @CRLF & _
"A18Z12I"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")