const regex = /[A-Z]{2,}\d+(*SKIP)(*FAIL)|[A-Z]\K\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Z]{2,}\\d+(*SKIP)(*FAIL)|[A-Z]\\K\\d+', 'gm')
const str = `A12B8Y9CC10
V5C8I17
KK18II9
I8VV22ZZ4S9U2
A18Z12I`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}