use strict;
my $str = 'A12B8Y9CC10
V5C8I17
KK18II9
I8VV22ZZ4S9U2
A18Z12I';
my $regex = qr/[A-Z]{2,}\d+(*SKIP)(*FAIL)|[A-Z]\K\d+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}