using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[A-Z]+)[0-9]+";
string substitution = @"\1";
string input = @"ABCDFE908787";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}