const regex = /(?:[A-Z]+)[0-9]+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:[A-Z]+)[0-9]+', '')
const str = `ABCDFE908787`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);