$re = '/\b\w{3,8}\b/m';
$str = 'words with length three to eight
foo
baz bar
#foo #baz# #bar123#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);