import re
regex = re.compile(r"\b\w{3,8}\b", flags=re.MULTILINE)
test_str = ("words with length three to eight\n"
"foo\n"
"baz bar\n"
"#foo #baz# #bar123#")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")