re = /\b\w{3,8}\b/m
str = 'words with length three to eight
foo
baz bar
#foo #baz# #bar123#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end