package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}
`)
var str = `10.20.20.20
455.22.677.999
ERR.YY.II.II`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}