$re = '/\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}
/m';
$str = '10.20.20.20
455.22.677.999
ERR.YY.II.II';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);