re = /\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3}
/m
str = '10.20.20.20
455.22.677.999
ERR.YY.II.II'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end