#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)2\d{3}03\d{2}"
Local $sString = "Brachyglottis laxifolia n214_03 slope dbot20200307_090740.jpg" & @CRLF & _
"" & @CRLF & _
"Acaena saccatipula n214 LeeSayBarb dbot20201101_664" & @CRLF & _
"" & @CRLF & _
"chionochloa rigida mono n1 ibot20190302_101814.jpg" & @CRLF & _
"" & @CRLF & _
"Geranium traversii n214_410 dbot20191225_501"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")