re = /2\d{3}03\d{2}/m
str = 'Brachyglottis laxifolia n214_03 slope dbot20200307_090740.jpg
Acaena saccatipula n214 LeeSayBarb dbot20201101_664
chionochloa rigida mono n1 ibot20190302_101814.jpg
Geranium traversii n214_410 dbot20191225_501'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end