import re
regex = re.compile(r"2\d{3}03\d{2}", flags=re.MULTILINE)
test_str = ("Brachyglottis laxifolia n214_03 slope dbot20200307_090740.jpg\n\n"
"Acaena saccatipula n214 LeeSayBarb dbot20201101_664\n\n"
"chionochloa rigida mono n1 ibot20190302_101814.jpg\n\n"
"Geranium traversii n214_410 dbot20191225_501")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")